UV editor not showing UV maps

Ask about specific settings, like fabric properties, or the difference between the sewing tools. These would be things you would expect to see in a software manual.
Post Reply
eirene
Posts: 2
Joined: Sun Jun 24, 2018 7:38 am

UV editor not showing UV maps

Post by eirene »

Hi, I am making a dress in MD 7.5 using a pre-existing template from MD, specifically a woman's shirt. I modified it, then I added other pieces, like a skirt, a corset, etc. Now my issue is that the UV editor only shows the UV maps for the templates, so I can see the buttons, the shirt... but no skirt, no corset.
This means when I export the model into blender I have to mark seams and unwrap everything else, which is extremely annoying.
Any tips please?
User avatar
LoriGriffiths
Posts: 478
Joined: Mon Jun 08, 2015 4:39 pm

Re: UV editor not showing UV maps

Post by LoriGriffiths »

That is very strange. I don't use the templates, so this isn't something that I've seen. It sounds like a bug to me. Have you tried reporting it to MD through their Issue system?
eirene
Posts: 2
Joined: Sun Jun 24, 2018 7:38 am

Re: UV editor not showing UV maps

Post by eirene »

Not yet, I was hoping it would be a known issue, or that I just forgot to tick/untick something while exporting.
I used a workaround that worked almost perfectly:
I took a snapshot of the patterns I designed.
Then I saved the garment without those patterns.
After this I opened a new file, used that snapshot as background image, traced the new patterns and remade those, making sure the UV maps were correct in the UV editor.
At that point I added the saved garment (the shirt template), and sewed that to the other pieces.
Only the corset's UV didn't export at all and I had to mark seams and unwrap it manually.
I still hope somebody has a better way to fix this :)
User avatar
wetcircuit
Posts: 52
Joined: Sun Jun 21, 2015 1:11 pm
Location: nyc
Contact:

Re: UV editor not showing UV maps

Post by wetcircuit »

:shock: I just hit this issue. I only have a couple of buttons in the UV Editor. I can't find any way to bring back the clothing patterns.
Screen Shot 2018-08-23 at 12.25.22 PM.png
Screen Shot 2018-08-23 at 12.25.22 PM.png (155.7 KiB) Viewed 6979 times
Seems to be an issue involving the Modular function…. :(
User avatar
LoriGriffiths
Posts: 478
Joined: Mon Jun 08, 2015 4:39 pm

Re: UV editor not showing UV maps

Post by LoriGriffiths »

Wow, that's awful. MD did add something called Remove Modular Relationship. Maybe if you did this the pattern would just be "regular" and work? Just guessing here.

Right-Click the modular block > Remove Modular Relationship
User avatar
wetcircuit
Posts: 52
Joined: Sun Jun 21, 2015 1:11 pm
Location: nyc
Contact:

Re: UV editor not showing UV maps

Post by wetcircuit »

Thank you for the suggestion. I tried it too but no good. I can't get the UV maps to show on a new (modular) garment in the same project. I think that project is toast.

I have gone to a back up where the UV Editor still shows everything… And I noticed something.

I had arranged the UV Editor and then later replaced one of the modules. I can't say for certain that caused it, but that is definitely something I did.

FYI… YMMV
User avatar
wetcircuit
Posts: 52
Joined: Sun Jun 21, 2015 1:11 pm
Location: nyc
Contact:

Re: UV editor not showing UV maps

Post by wetcircuit »

I also edited the buttons...
Post Reply